Error when creating a support request to iAdvize
Incident Report for iAdvize (HA)
Resolved
The issue has been resolved by our ticketing software provider: ticket creation through our Help Center is now restored.
Posted Sep 09, 2020 - 17:01 CEST
Identified
Due to an incident on the provider of our ticketing software, it is currently impossible to create support requests through our help center.

Until the situation comes back to normal, you can send your requests to help@iadvize.com
Posted Sep 09, 2020 - 14:02 CEST