Service disruption - Facebook and Messenger messages
Incident Report for iAdvize (HA)
Postmortem

The problem has been initially caused by the reception of a message from Facebook having a format that our application could not process. As a consequence the application kept on restarting on this specific message, preventing new incoming messages to be processed after that.

1) When the issue has been identified, an intervention has been performed in order to prevent the service from crashing. 2) Right after an evolution has been developed and pushed to production to support the message format that caused the problem.

Thanks to these actions this problem should not occur in the future.

Posted 10 months ago. Jul 27, 2018 - 16:57 CEST

Resolved
A patch has been deployed, all Facebook / Messenger messages can now be displayed properly.

The situation is now back to normal, this is incident is now resolved.
Posted 10 months ago. Jul 27, 2018 - 10:10 CEST
Investigating
There is currently an incident impacting Facebook and Messenger messages, since midnight we are not able to display new messages and new conversations in the picking list.

We are working to restore the service and will update you as we learn more.
Posted 10 months ago. Jul 27, 2018 - 09:22 CEST
This incident affected: Conversation message delivery (Messenger conversation service, Facebook conversation service).