Service disruption - iAdvize not reachable
Incident Report for iAdvize (HA)
Postmortem

The migration from our historical to our new infrastructure provider allowed us to double the RAM size of the servers hosting our MySQL database. During this intervention, every custom MySQL server configuration parameters have been ported from the old MySQL server to the new one.

Nevertheless, the RAM size increase of the servers was not properly taken into account in the new configuration, as the buffer size kept using a value fit for our old RAM size, but too small for our new RAM power. As a consequence, MySQL was sometimes retrieving data from disk, instead of from memory, which degraded performance significantly and created slowdowns on the platform.

Everything went back to normal after doubling the MySQL buffer size, reflecting our new RAM size.

Posted Jan 15, 2018 - 14:53 CET

Resolved
Following our infrastructure migration, the sizing of our load balancers was not sufficient to handle the incoming traffic on our platform. Since the load balancers were overloaded, iAdvize was not reachable from 10:19 UTC+01:00. The problem has been solved by increasing our load balancers pool, everything is back to normal since 10:31 UTC+01:00.
Posted Dec 14, 2017 - 12:02 CET
Monitoring
iAdvize platform is back. We are monitoring the activity.
Posted Dec 14, 2017 - 10:33 CET
Investigating
The iAdvize solution is currently down. We are actively working on a fix.
Thank you for your understanding
Posted Dec 14, 2017 - 10:23 CET