Service disruption on social channels and SMS
Incident Report for iAdvize (HA)
Postmortem

On December 19th we experienced service disruptions on our social channels & SMS between 1:00am (UTC+1) and 9:35am (UTC+1).
During this incident it was not possible to receive incoming messages from Messenger / Facebook / Twitter / SMS, and it was not possible to reply existing conversations on these channels.

Chronology of the incident:
- This issue has been caused by the expiration at 01:00am (UTC+1) of a SSL certificate used to contact an external provider
- As a corrective action, our provider has renewed the certificate at 09:35am (UTC+1)
- Everything went back to normal after this action at 9:35am (UTC+1)

After that our technical team has reprocessed the messages sent during the incident, so they can gradually appear in the iAdvize conversation panel.

In order to prevent this issue from happening in the future, we asked our service provider to ensure that certificate renewal is automatically done on their side.

Posted 5 months ago. Dec 19, 2018 - 10:26 CET

Resolved
This cause of the problem has been identified on our service provider side, due to a SSL certificate expiration.

After the intervention of this service provider, the situation is back to normal. Now you can reply social & SMS conversations.
Messages sent during the incident will gradually appear in the picking list, so you may still experience delay before they are all visible.

Thank you for your patience.
Posted 5 months ago. Dec 19, 2018 - 09:47 CET
Investigating
There is currently an incident impacting the social channels and SMS. Incoming conversations may not appear in the picking list, and it is impossible to reply existing messages (with the display "No account available to respond to this message").

We are working to restore the service and will update you as we learn more.
Posted 5 months ago. Dec 19, 2018 - 09:12 CET
This incident affected: Conversation message delivery (Messenger conversation service, Twitter conversation service, Facebook conversation service).