Impossible to contact iAdvize assistance by email
Incident Report for iAdvize (HA)
Resolved
The incident has been solved.
All emails sent to help@iadvize.com since Tuesday 26th afternoon will be gradually processed (new tickets will be manually created and comments of existing tickets will be collected).
We appreciate your patience as we worked through this and apologize for the inconvenience.
Posted 6 months ago. Mar 28, 2019 - 12:13 CET
Investigating
There is currently an incident impacting ticket creation when sending an email to help@iadvize.com 
We are working on it and will update you as we learn more. 
Until then, it is still possible to create a ticket through the iAdvize Help and Support Center : https://help.iadvize.com/hc/en-gb/articles/203549386
Posted 6 months ago. Mar 27, 2019 - 16:17 CET
This incident affected: Administrator Web App.